aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-inc-latest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-inc-latest/APKBUILD')
-rw-r--r--main/perl-inc-latest/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/perl-inc-latest/APKBUILD b/main/perl-inc-latest/APKBUILD
new file mode 100644
index 00000000000..19d87747813
--- /dev/null
+++ b/main/perl-inc-latest/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=perl-inc-latest
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=inc-latest
+pkgver=0.500
+pkgrel=0
+pkgdesc="use modules bundled in inc/ if they are newer than installed ones"
+url="https://metacpan.org/release/inc-latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/inc-latest-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="b312d1dfce963322796bc0127f0ecd82c12baacf9e5df40d9acc093221edd80f3696ce6d9f185ed24b21983147363d1d0ff3e273b8b5ce7559a6f16983a1385c inc-latest-0.500.tar.gz"