aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-inline/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-inline/APKBUILD')
-rw-r--r--main/perl-inline/APKBUILD35
1 files changed, 16 insertions, 19 deletions
diff --git a/main/perl-inline/APKBUILD b/main/perl-inline/APKBUILD
index d5d171e40b6..e1b299388f9 100644
--- a/main/perl-inline/APKBUILD
+++ b/main/perl-inline/APKBUILD
@@ -1,41 +1,38 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-inline
-_realname=Inline
-pkgver=0.80
-pkgrel=1
+_pkgname=Inline
+pkgver=0.81
+pkgrel=0
pkgdesc="Write Perl subroutines in other programming languages"
url="http://search.cpan.org/~ingy/Inline/"
arch="noarch"
license="Artistic-1.0 GPL+"
depends="perl"
makedepends="perl-dev"
-install=
+checkdepends="perl-test-warn"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/I/IN/INGY/$_realname-$pkgver.tar.gz
- "
-
-_builddir="$srcdir"/$_realname-$pkgver
+source="https://cpan.metacpan.org/authors/id/T/TI/TINITA/Inline-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
- cd $_builddir
- return 0
+ default_prepare
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd $_builddir
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+check() {
+ make test
}
package() {
- cd "$_builddir"
make DESTDIR="$pkgdir" install
- # creates file collision among perl modules
- find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="510bbac46e727bcaf240b7feac2646c9 Inline-0.80.tar.gz"
-sha256sums="7e2bd984b1ebd43e336b937896463f2c6cb682c956cbd2c311a464363d2ccef6 Inline-0.80.tar.gz"
-sha512sums="e64f7752f32fd07c7c7a975429e04730f2987c9588f99b95502d4e5c87d458736a606c03943a68660940c3987cd632ad2f75ec3862342956c1754b1aca86e0bb Inline-0.80.tar.gz"
+sha512sums="ea52647af6a51e6902d78c448e53814f1f3de225d3cf5530764d880f604ddea6dc6e6272619a918c213ce611bf3643f602e779d56e503245987b86363cb0501a Inline-0.81.tar.gz"