aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-io-tty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-io-tty/APKBUILD')
-rw-r--r--main/perl-io-tty/APKBUILD40
1 files changed, 22 insertions, 18 deletions
diff --git a/main/perl-io-tty/APKBUILD b/main/perl-io-tty/APKBUILD
index 200852b9f91..932ac1287e4 100644
--- a/main/perl-io-tty/APKBUILD
+++ b/main/perl-io-tty/APKBUILD
@@ -1,42 +1,46 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-io-tty
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=IO-Tty
-pkgver=1.12
-pkgrel=7
+pkgver=1.20
+pkgrel=0
pkgdesc="Pseudo ttys and constants"
-url="https://metacpan.org/pod/IO::Tty"
+url="https://metacpan.org/release/IO-Tty/"
arch="all"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/T/TO/TODDR/IO-Tty-$pkgver.tar.gz
+ disable-failing-test.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
+# On the builders, tests fail randomly on ARM when using Perl 5.36.0
+# Error: "Failed test '$maxlen >= 200 (41)' at t/test.t line 235."
+case "$CARCH" in
+ arm*|aarch64) options="$options !check" ;;
+esac
build() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="11695a1a516b3bd1b90ce75ff0ce3e6d IO-Tty-1.12.tar.gz"
-sha256sums="a2ef8770d3309178203f8c8ac25e623e63cf76e97830fd3be280ade1a555290d IO-Tty-1.12.tar.gz"
-sha512sums="23733e7832a0de370952420df8a781f85d28ff60eb4cd55be22147337bf5587f4e1ec7fcfc190ae3ad1fd9df0f9697f2d647e00739f4a2927b1ac9c81435454d IO-Tty-1.12.tar.gz"
+sha512sums="
+a411dcc3da4adf4913ceaca7d97198041c6870ac8b579a1d5c2517d984fab4cc8108962b23ee694da9e0c952f35d695e636ff35589873b95a86c2bf8c1838ee4 IO-Tty-1.20.tar.gz
+37c8aae630d4ee80b20b3540ed7fb5840b9a995e2ee489cbad8ace503ac9f596b38d01cb46e55d339898cc60d23581b451b71b27a6b871bc8ef84d1be2600427 disable-failing-test.patch
+"