aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-io-tty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-io-tty/APKBUILD')
-rw-r--r--main/perl-io-tty/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/main/perl-io-tty/APKBUILD b/main/perl-io-tty/APKBUILD
index 19a1b4d4b44..932ac1287e4 100644
--- a/main/perl-io-tty/APKBUILD
+++ b/main/perl-io-tty/APKBUILD
@@ -4,8 +4,8 @@
pkgname=perl-io-tty
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=IO-Tty
-pkgver=1.16
-pkgrel=3
+pkgver=1.20
+pkgrel=0
pkgdesc="Pseudo ttys and constants"
url="https://metacpan.org/release/IO-Tty/"
arch="all"
@@ -14,9 +14,16 @@ depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/T/TO/TODDR/IO-Tty-$pkgver.tar.gz
-disable-failing-test.patch"
+ disable-failing-test.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
+# On the builders, tests fail randomly on ARM when using Perl 5.36.0
+# Error: "Failed test '$maxlen >= 200 (41)' at t/test.t line 235."
+case "$CARCH" in
+ arm*|aarch64) options="$options !check" ;;
+esac
+
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
@@ -33,8 +40,7 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-
sha512sums="
-a6f28a8796992645c4b2ddab5b3a76f49e61a891442078ef8249088d077108ea63bb4c8000cf39d15d13801b82e1cfcbe6ea0e6542789ab28385d83e03f6a9de IO-Tty-1.16.tar.gz
+a411dcc3da4adf4913ceaca7d97198041c6870ac8b579a1d5c2517d984fab4cc8108962b23ee694da9e0c952f35d695e636ff35589873b95a86c2bf8c1838ee4 IO-Tty-1.20.tar.gz
37c8aae630d4ee80b20b3540ed7fb5840b9a995e2ee489cbad8ace503ac9f596b38d01cb46e55d339898cc60d23581b451b71b27a6b871bc8ef84d1be2600427 disable-failing-test.patch
"