aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-mime-types/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-mime-types/APKBUILD')
-rw-r--r--main/perl-mime-types/APKBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/main/perl-mime-types/APKBUILD b/main/perl-mime-types/APKBUILD
index 5e32565542f..71d80c81685 100644
--- a/main/perl-mime-types/APKBUILD
+++ b/main/perl-mime-types/APKBUILD
@@ -1,11 +1,11 @@
-# Automatically generated by apkbuild-cpan, template 3
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-mime-types
+pkgver=2.26
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=MIME-Types
-pkgver=2.18
-pkgrel=0
pkgdesc="Definition of MIME types"
url="https://metacpan.org/release/MIME-Types/"
arch="noarch"
@@ -17,7 +17,10 @@ builddir="$srcdir/$_pkgreal-$pkgver"
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
@@ -28,7 +31,15 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="770e63a48b40c94f1728e67f6a69029f51e125562d11008f26a5e1a6b85d30fb45bcbd1f8e080f664542b81de94695972012815e07f0ecd007a11efb32005df1 MIME-Types-2.18.tar.gz"
+doc() {
+ local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+ amove "${file#"$pkgdir"}"
+ done
+ default_doc
+}
+
+sha512sums="
+cde3a8c6cbde16143732cf2ac4d648eff167917970357daf0162370cbba375b2aa546af472a73b2a4b26086919ddcc49bd9da999251946a40aee8abb60af2d75 MIME-Types-2.26.tar.gz
+"