aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-mime-types
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-mime-types')
-rw-r--r--main/perl-mime-types/APKBUILD49
1 files changed, 23 insertions, 26 deletions
diff --git a/main/perl-mime-types/APKBUILD b/main/perl-mime-types/APKBUILD
index df536954a25..71d80c81685 100644
--- a/main/perl-mime-types/APKBUILD
+++ b/main/perl-mime-types/APKBUILD
@@ -1,48 +1,45 @@
-# Automatically generated by apkbuild-cpan, template 2
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-mime-types
+pkgver=2.26
+pkgrel=0
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=MIME-Types
-pkgver=2.17
-pkgrel=1
pkgdesc="Definition of MIME types"
url="https://metacpan.org/release/MIME-Types/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/M/MA/MARKOV/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/M/MA/MARKOV/MIME-Types-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
+build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
+ make
}
-build() {
- cd "$builddir"
+check() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-check() {
- cd "$builddir"
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make test
+doc() {
+ local file; find "$pkgdir" -name "*.pod" | while read -r file; do
+ amove "${file#"$pkgdir"}"
+ done
+ default_doc
}
-sha512sums="a834ddfa70fbaa5688a2a35626c489a48448e273638312609faaa8fbf07ba656254d1f907ba5f25518e93fd62b7b9265eec700c38c8446876dca24e07d8b15c4 MIME-Types-2.17.tar.gz"
+sha512sums="
+cde3a8c6cbde16143732cf2ac4d648eff167917970357daf0162370cbba375b2aa546af472a73b2a4b26086919ddcc49bd9da999251946a40aee8abb60af2d75 MIME-Types-2.26.tar.gz
+"