aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-module-implementation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-module-implementation/APKBUILD')
-rw-r--r--main/perl-module-implementation/APKBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/main/perl-module-implementation/APKBUILD b/main/perl-module-implementation/APKBUILD
index 12f05c608ad..8d78f5b0ae2 100644
--- a/main/perl-module-implementation/APKBUILD
+++ b/main/perl-module-implementation/APKBUILD
@@ -1,46 +1,38 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-module-implementation
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Module-Implementation
pkgver=0.09
-pkgrel=2
+pkgrel=5
pkgdesc="Loads one of several alternate underlying implementations for a module"
url="https://metacpan.org/release/Module-Implementation/"
arch="noarch"
license="Artistic-2.0"
-cpandepends="perl-module-runtime perl-try-tiny perl-test-taint"
-cpanmakedepends="perl-test-fatal perl-test-requires "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl perl-module-runtime perl-try-tiny"
+makedepends="perl-dev"
+checkdepends="perl-test-requires perl-test-fatal"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Module-Implementation-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
- make test
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="049f967ba1bd8a3914968b34006030ae318d99ac629a0f34736f1c2b5392490c30aa0914e777eaefda7f0f58755d2d3363a266b90db59b53fe145ef68e1d953c Module-Implementation-0.09.tar.gz"
+sha512sums="
+049f967ba1bd8a3914968b34006030ae318d99ac629a0f34736f1c2b5392490c30aa0914e777eaefda7f0f58755d2d3363a266b90db59b53fe145ef68e1d953c Module-Implementation-0.09.tar.gz
+"