aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-params-validate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-params-validate/APKBUILD')
-rw-r--r--main/perl-params-validate/APKBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/main/perl-params-validate/APKBUILD b/main/perl-params-validate/APKBUILD
index 196d8018aa8..02538320a5b 100644
--- a/main/perl-params-validate/APKBUILD
+++ b/main/perl-params-validate/APKBUILD
@@ -1,43 +1,36 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-params-validate
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Params-Validate
-pkgver=1.29
-pkgrel=3
+pkgver=1.31
+pkgrel=2
pkgdesc="Validate method/function parameters"
url="https://metacpan.org/release/Params-Validate/"
arch="all"
license="Artistic-2.0"
-cpandepends="perl-module-implementation"
-cpanmakedepends="perl-test-fatal perl-module-implementation perl-test-requires"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends perl-module-build"
+depends="perl perl-module-implementation"
+makedepends="perl-dev perl-module-build"
+checkdepends="perl-test-requires perl-test-fatal"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Params-Validate-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- perl Build.PL installdirs=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
- ./Build install destdir="$pkgdir"
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="afa887d1ce60d38b82cbf3ad88fb892f473e0fa45db528b68e66bbb800058af453180cc96afddae56a2cdad8ec531a587e7aac36b6869c489caa6dd36a57a385 Params-Validate-1.29.tar.gz"
+sha512sums="
+8b20db8725df35b4dd9201dea764254d993cfa8a73b2ccebd7a9ba492cde36b589f66c26b287fe2f0ec1ebfafd53872cd164bee1727d1453265e030a927556d9 Params-Validate-1.31.tar.gz
+"