aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-path-class/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-path-class/APKBUILD')
-rw-r--r--main/perl-path-class/APKBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/main/perl-path-class/APKBUILD b/main/perl-path-class/APKBUILD
index cc403ca77bc..587ff78c140 100644
--- a/main/perl-path-class/APKBUILD
+++ b/main/perl-path-class/APKBUILD
@@ -1,38 +1,36 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-path-class
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Path-Class
pkgver=0.37
-pkgrel=2
+pkgrel=4
pkgdesc="Cross-platform path specification manipulation"
url="https://metacpan.org/release/Path-Class/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends perl-module-build"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/K/KW/KWILLIAMS/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/K/KW/KWILLIAMS/Path-Class-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- perl Build.PL installdirs=vendor || return 1
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
}
-build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- ./Build && ./Build test
+check() {
+ ./Build test
}
package() {
- cd "$_builddir"
- ./Build install destdir="$pkgdir" || return 1
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="044d86f85eebff96bdff8fc11e97884eb4e06d56ecd2d3bfdc045135da6f08c40e644e0e5c1a779a8ef5d6c7c04e159e47721b4e637a92fed7d298b5f798ef83 Path-Class-0.37.tar.gz"
+sha512sums="
+044d86f85eebff96bdff8fc11e97884eb4e06d56ecd2d3bfdc045135da6f08c40e644e0e5c1a779a8ef5d6c7c04e159e47721b4e637a92fed7d298b5f798ef83 Path-Class-0.37.tar.gz
+"