aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-path-tiny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-path-tiny/APKBUILD')
-rw-r--r--main/perl-path-tiny/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/main/perl-path-tiny/APKBUILD b/main/perl-path-tiny/APKBUILD
index 26cd2d93eda..936a9aab92d 100644
--- a/main/perl-path-tiny/APKBUILD
+++ b/main/perl-path-tiny/APKBUILD
@@ -1,33 +1,30 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-path-tiny
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Path-Tiny
-pkgver=0.116
+pkgver=0.118
pkgrel=0
pkgdesc="File path utility"
-url="https://metacpan.org/release/Path-Tiny"
+url="https://metacpan.org/release/Path-Tiny/"
arch="noarch"
license="Apache-2.0"
depends="perl"
-makedepends="perl-dev perl-test-mockrandom perl-test-failwarnings"
+makedepends="perl-dev"
+checkdepends="perl-test-failwarnings perl-test-mockrandom"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/Path-Tiny-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
@@ -36,4 +33,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="f365af6a698452121f3cf784bd1990a33da088e6f777d8ed412fa12c95f9cb4a109dead98d3549fd916373ee38e4b9c9a09f7fdf42d7e6e4f32bfddc950da6fa Path-Tiny-0.116.tar.gz"
+sha512sums="cca91e7fcb099aa7aec73135d295f3f32366ca4bec17201183d3e5cb69cf7e58f2554e162318bc34dc787689bab338286937c0e83065d8aff4d4862aa53efc61 Path-Tiny-0.118.tar.gz"