aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-regexp-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-regexp-common/APKBUILD')
-rw-r--r--main/perl-regexp-common/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/main/perl-regexp-common/APKBUILD b/main/perl-regexp-common/APKBUILD
index cf30e674169..8c991837463 100644
--- a/main/perl-regexp-common/APKBUILD
+++ b/main/perl-regexp-common/APKBUILD
@@ -9,7 +9,7 @@ pkgdesc="Provide commonly requested regular expressions"
url="https://metacpan.org/release/Regexp-Common/"
arch="noarch"
license="MIT"
-makedepends="perl-dev"
+depends="perl"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/A/AB/ABIGAIL/$_pkgreal-$pkgver.tar.gz"
@@ -17,25 +17,20 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
-
- cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}