aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-sub-identify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-sub-identify/APKBUILD')
-rw-r--r--main/perl-sub-identify/APKBUILD40
1 files changed, 17 insertions, 23 deletions
diff --git a/main/perl-sub-identify/APKBUILD b/main/perl-sub-identify/APKBUILD
index fc15621b6d9..f44e702ac9a 100644
--- a/main/perl-sub-identify/APKBUILD
+++ b/main/perl-sub-identify/APKBUILD
@@ -1,43 +1,37 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-sub-identify
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Sub-Identify
pkgver=0.14
-pkgrel=5
+pkgrel=10
pkgdesc="Retrieve names of code references"
url="https://metacpan.org/release/Sub-Identify/"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/R/RG/RGARCIA/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/R/RG/RGARCIA/Sub-Identify-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-check() {
- cd "$builddir"
- make test
-}
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="f69f542c84c5c3ca1f1c7f5f58fd2cf19279a65229f43117c31f24ab0e49d5f329bef2bc00f22252fd2e52b4e17f16b279dac438920668e046e59f2e22e52c14 Sub-Identify-0.14.tar.gz"
+sha512sums="
+f69f542c84c5c3ca1f1c7f5f58fd2cf19279a65229f43117c31f24ab0e49d5f329bef2bc00f22252fd2e52b4e17f16b279dac438920668e046e59f2e22e52c14 Sub-Identify-0.14.tar.gz
+"