aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-sub-install/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-sub-install/APKBUILD')
-rw-r--r--main/perl-sub-install/APKBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/main/perl-sub-install/APKBUILD b/main/perl-sub-install/APKBUILD
index 0571f45302d..be5f8d08412 100644
--- a/main/perl-sub-install/APKBUILD
+++ b/main/perl-sub-install/APKBUILD
@@ -1,39 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-sub-install
-pkgver=0.928
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Sub-Install
+pkgver=0.929
pkgrel=2
-pkgdesc="Sub::Install perl module"
+pkgdesc="install subroutines into packages easily"
url="https://metacpan.org/release/Sub-Install/"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Sub-Install-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir"/Sub-Install-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="3f25df9f5992075968830d4235e9f6520c526331b9180391e41483241d43253a61ad8dc381d77aaeb6c6fb841cfc5c097598e62abb46208894275c393a133ade Sub-Install-0.928.tar.gz"
+sha512sums="
+f51992531607af97ff6b8700bf23a2918261d05f24886781f36e2676c130df5d109a42ad3d6f8d089a6ee2c050af27ec5fc2ef9610ee993eca6549866a4fe8d7 Sub-Install-0.929.tar.gz
+"