aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-fatal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-test-fatal/APKBUILD')
-rw-r--r--main/perl-test-fatal/APKBUILD37
1 files changed, 16 insertions, 21 deletions
diff --git a/main/perl-test-fatal/APKBUILD b/main/perl-test-fatal/APKBUILD
index 87f4f8a9cc6..9af494bf50a 100644
--- a/main/perl-test-fatal/APKBUILD
+++ b/main/perl-test-fatal/APKBUILD
@@ -1,42 +1,37 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=perl-test-fatal
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Test-Fatal
-pkgver=0.014
-pkgrel=2
+pkgver=0.017
+pkgrel=1
pkgdesc="incredibly simple helpers for testing code with exceptions"
url="https://metacpan.org/release/Test-Fatal/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-try-tiny"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-try-tiny"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Test-Fatal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="339d9b33231f8c8d93c0f9374a51458d004568a2f3e28471976e954c35d27efd348f68fb56e3cabd11dc47d37e7ce46282eba967c156ba5081811d221c6a7523 Test-Fatal-0.014.tar.gz"
+sha512sums="
+e88bb9749bd1cbc4ed169e13bcd5a1ac7411873d8ae00d8b7ecf1dfc39ed9a02f0286d885876913c69b5c90033144d5fda6a5517ef64175d13e284d3c971a6e7 Test-Fatal-0.017.tar.gz
+"