aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-refcount/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-test-refcount/APKBUILD')
-rw-r--r--main/perl-test-refcount/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/main/perl-test-refcount/APKBUILD b/main/perl-test-refcount/APKBUILD
index 8d36c255566..6e15f8a47a0 100644
--- a/main/perl-test-refcount/APKBUILD
+++ b/main/perl-test-refcount/APKBUILD
@@ -1,25 +1,24 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=perl-test-refcount
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Test-Refcount
pkgver=0.10
-pkgrel=3
+pkgrel=5
pkgdesc="assert reference counts on objects"
-url="https://metacpan.org/release/Test-Refcount"
+url="https://metacpan.org/release/Test-Refcount/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Test-Refcount-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
- perl Build.PL installdirs=vendor
-}
-
build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
./Build
}
@@ -28,8 +27,10 @@ check() {
}
package() {
- ./Build install destdir="$pkgdir"
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="7fac2a6bcb96da0ed61c53aaa2278e1ac998bd62314b95f307fe6ee032fd7d89264968f3ad78066186b112af0ba45960d5d1c81822bcd5f218418ea81236c4e1 Test-Refcount-0.10.tar.gz"
+sha512sums="
+7fac2a6bcb96da0ed61c53aaa2278e1ac998bd62314b95f307fe6ee032fd7d89264968f3ad78066186b112af0ba45960d5d1c81822bcd5f218418ea81236c4e1 Test-Refcount-0.10.tar.gz
+"