aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-text-password-pronounceable/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-text-password-pronounceable/APKBUILD')
-rw-r--r--main/perl-text-password-pronounceable/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/main/perl-text-password-pronounceable/APKBUILD b/main/perl-text-password-pronounceable/APKBUILD
index 7b0b1f3e25b..d20f75d4c8d 100644
--- a/main/perl-text-password-pronounceable/APKBUILD
+++ b/main/perl-text-password-pronounceable/APKBUILD
@@ -2,31 +2,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-text-password-pronounceable
pkgver=0.30
-pkgrel=3
+pkgrel=5
pkgdesc="Text::Password::Pronounceable perl module"
url="https://metacpan.org/release/Text-Password-Pronounceable/"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="Artistic-1.0-Perl OR GPL-1.0-or-later"
depends="perl"
-makedepends="perl-dev perl-module-install"
+makedepends="perl-module-install"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/T/TS/TSIBLEY/Text-Password-Pronounceable-$pkgver.tar.gz"
builddir="$srcdir/Text-Password-Pronounceable-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}