aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-text-soundex/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-text-soundex/APKBUILD')
-rw-r--r--main/perl-text-soundex/APKBUILD42
1 files changed, 20 insertions, 22 deletions
diff --git a/main/perl-text-soundex/APKBUILD b/main/perl-text-soundex/APKBUILD
index 52af9a99342..c164d338e3f 100644
--- a/main/perl-text-soundex/APKBUILD
+++ b/main/perl-text-soundex/APKBUILD
@@ -1,39 +1,37 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-text-soundex
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Text-Soundex
pkgver=3.05
-pkgrel=5
-pkgdesc="Implementation of the soundex algorithm"
+pkgrel=9
+pkgdesc="Perl module for Text-Soundex"
url="https://metacpan.org/release/Text-Soundex/"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Text-Soundex-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="f7ea405cb5960cc2e3f5e257c18c1bbb499c5244ad6a6d14612f07329fd2177ad71dcdde85129e65c65541d61e45d7e9e4097c37ca6cead9783838900b3ebbec Text-Soundex-3.05.tar.gz"
+sha512sums="
+f7ea405cb5960cc2e3f5e257c18c1bbb499c5244ad6a6d14612f07329fd2177ad71dcdde85129e65c65541d61e45d7e9e4097c37ca6cead9783838900b3ebbec Text-Soundex-3.05.tar.gz
+"