aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-text-vfile-asdata/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-text-vfile-asdata/APKBUILD')
-rw-r--r--main/perl-text-vfile-asdata/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/perl-text-vfile-asdata/APKBUILD b/main/perl-text-vfile-asdata/APKBUILD
new file mode 100644
index 00000000000..dca99e37bae
--- /dev/null
+++ b/main/perl-text-vfile-asdata/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-text-vfile-asdata
+_pkgreal=Text-vFile-asData
+pkgver=0.07
+pkgrel=0
+pkgdesc="parse vFile formatted files into data structures"
+url="http://search.cpan.org/dist/Text-vFile-asData/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-class-accessor-chained"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RC/RCLAMP/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="1f0fc1fbef2111a936db3eb4678ddccc Text-vFile-asData-0.07.tar.gz"