aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-try-tiny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-try-tiny/APKBUILD')
-rw-r--r--main/perl-try-tiny/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/main/perl-try-tiny/APKBUILD b/main/perl-try-tiny/APKBUILD
index 8b152d8e9b4..0115df9cc7c 100644
--- a/main/perl-try-tiny/APKBUILD
+++ b/main/perl-try-tiny/APKBUILD
@@ -1,31 +1,30 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Sheila Aman <sheila@vulpine.house>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-try-tiny
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Try-Tiny
-pkgver=0.30
-pkgrel=3
-pkgdesc="minimal try/catch with proper preservation of \$@"
-url="https://search.cpan.org/dist/Try-Tiny/"
+pkgver=0.31
+pkgrel=2
+pkgdesc="Minimal try/catch with proper preservation of \$@"
+url="https://metacpan.org/release/Try-Tiny/"
arch="noarch"
license="MIT"
-depends="perl perl-capture-tiny perl-pod-coverage"
-makedepends="grep perl-sub-name"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/Try-Tiny-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
@@ -34,4 +33,6 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="f523736ab0504ca0f7150be312e62988c4b9473a9e8469b0746dc8364945e2922c64c92e95e6c2b5792c5d6399dabea3d00aa45c065155b95519d5658a07216c Try-Tiny-0.30.tar.gz"
+sha512sums="
+1a3c852e56797d81da60a4f4887cb70fc575eca83d10b8cd12fe5d5d0008a967801218f3a5277a2f1347ade95b9515c1f237333e491742d06614c0beecf44768 Try-Tiny-0.31.tar.gz
+"