aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-want/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-want/APKBUILD')
-rw-r--r--main/perl-want/APKBUILD42
1 files changed, 20 insertions, 22 deletions
diff --git a/main/perl-want/APKBUILD b/main/perl-want/APKBUILD
index 81c9ab3e1fb..3d396e33e5b 100644
--- a/main/perl-want/APKBUILD
+++ b/main/perl-want/APKBUILD
@@ -1,39 +1,37 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-want
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Want
pkgver=0.29
-pkgrel=6
-pkgdesc="unknown"
+pkgrel=10
+pkgdesc="Perl module for Want"
url="https://metacpan.org/release/Want/"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/R/RO/ROBIN/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/R/RO/ROBIN/Want-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="08df985de16b5e9dd67d6ed38d319da2511e92098f95a861a5a695eed8d77eaf412671b626e4da29b536147ad4da4a8cfdfd789ef204dac240073091481f3c1a Want-0.29.tar.gz"
+sha512sums="
+08df985de16b5e9dd67d6ed38d319da2511e92098f95a861a5a695eed8d77eaf412671b626e4da29b536147ad4da4a8cfdfd789ef204dac240073091481f3c1a Want-0.29.tar.gz
+"