aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-www-robotrules
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-www-robotrules')
-rw-r--r--main/perl-www-robotrules/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/perl-www-robotrules/APKBUILD b/main/perl-www-robotrules/APKBUILD
index f860b96ffaa..c0d58e3940c 100644
--- a/main/perl-www-robotrules/APKBUILD
+++ b/main/perl-www-robotrules/APKBUILD
@@ -2,14 +2,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-www-robotrules
pkgver=6.02
-pkgrel=3
+pkgrel=5
pkgdesc="WWW::RobotRules perl module"
url="https://metacpan.org/release/WWW-RobotRules/"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="Artistic-1.0-Perl OR GPL-1.0-or-later"
depends="perl perl-uri"
-makedepends="perl-dev"
-install=""
replaces="perl-libwww"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/G/GA/GAAS/WWW-RobotRules-$pkgver.tar.gz"
@@ -17,18 +15,15 @@ source="https://cpan.metacpan.org/authors/id/G/GA/GAAS/WWW-RobotRules-$pkgver.ta
builddir="$srcdir"/WWW-RobotRules-$pkgver
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}