aboutsummaryrefslogtreecommitdiffstats
path: root/main/postfix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/postfix/APKBUILD')
-rw-r--r--main/postfix/APKBUILD25
1 files changed, 4 insertions, 21 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index c2e1485f083..5952532043b 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -2,17 +2,15 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
-pkgver=3.7.2
-pkgrel=3
+pkgver=3.9.0
+pkgrel=1
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="https://www.postfix.org/"
arch="all"
license="IPL-1.0 EPL-2.0"
-depends="musl>=1.1.24-r7"
makedepends="
coreutils
cyrus-sasl-dev
- hiredis-dev
icu-dev
libpq-dev
linux-headers
@@ -34,7 +32,6 @@ subpackages="
$pkgname-mysql:_mv_dict
$pkgname-pcre:_mv_dict
$pkgname-pgsql:_mv_dict
- $pkgname-redis:_mv_dict
$pkgname-sqlite:_mv_dict
$pkgname-stone
"
@@ -46,9 +43,6 @@ source="https://de.postfix.org/ftpmirror/official/postfix-$pkgver.tar.gz
$pkgname.initd
postfix-install.patch
lmdb-default.patch
- postfix-redis.patch
- dict_redis.c
- dict_redis.h
"
_shared_libs() {
@@ -63,7 +57,6 @@ prepare() {
-e "/^#define ALIAS_DB_MAP/s|:/etc/aliases|:/etc/postfix/aliases|" \
src/util/sys_defs.h
sed -i -e "s:/usr/local/:/usr/:g" conf/master.cf
- cp "$srcdir"/dict_redis.* src/global/
}
build() {
@@ -103,12 +96,6 @@ build() {
# lmdb (make it default)
ccargs="$ccargs -DHAS_LMDB $(pkg-config --cflags lmdb) -DDEF_DB_TYPE=\\\"lmdb\\\""
- # redis
- ccargs="$ccargs -DHAS_REDIS $(pkg-config --cflags hiredis)"
-
- #
- # AUXLIBS_CDB="$cdb_libs" \
-
# compile
make DEBUG="" \
OPT="$CFLAGS" \
@@ -120,7 +107,6 @@ build() {
AUXLIBS_PGSQL="$(pkg-config --libs libpq)" \
AUXLIBS_SQLITE="$(pkg-config --libs sqlite3)" \
AUXLIBS_LMDB="$(pkg-config --libs lmdb)" \
- AUXLIBS_REDIS="$(pkg-config --libs hiredis)" \
config_directory=/etc/postfix \
meta_directory=/etc/postfix \
daemon_directory=/usr/libexec/postfix \
@@ -171,7 +157,7 @@ package() {
"$pkgdir"/var/spool/postfix/public
cd "$pkgdir"/etc/postfix/
- for map in ldap mysql pcre pgsql sqlite lmdb redis; do
+ for map in ldap mysql pcre pgsql sqlite lmdb; do
msg "split $map"
_mvline "^\s*$map" "$map" dynamicmaps.cf
done
@@ -207,11 +193,8 @@ stone() {
find src/smtpstone -mindepth 1 -perm 0755 -exec cp {} "$subpkgdir"/usr/bin \;
}
sha512sums="
-23bb1af6bf3743c741f108da136f64613f9062d121dc459944ac192275335952cd309ffec6c380f5d36430605eec538c2549c3fdee9d4597f739d9d1b0a033fc postfix-3.7.2.tar.gz
+46faaf529a6d2edc5ea747ee0d73a028f7061a923da0ea4b1e1828d935b15f5782d83f7a8472e7c74b45ea0e96666c871efd352934bead28a88ddd3561ade324 postfix-3.9.0.tar.gz
2752e69c4e1857bdcf29444ffb458bca818bc60b9c77c20823c5f5b87c36cb5e0f3217a625a7fe5788d5bfcef7570a1f2149e1233fcd23ccf7ee14190aff47a2 postfix.initd
25cd34f23ca909d4e33aaf3239d1e397260abc7796d9a4456dee4f005682fd3a58aab8106126e5218c95bdddae415a3ef7e2223cd3b0d7b1e2bd76158bb7eaf8 postfix-install.patch
0769e2e503486f8dd6fa21f2c534ad7df7a9f1bb57dde2f0ad61863a3e615d0a6dc18132b27796eb28cd81afb2b4e97c65c9d490a391f835aa3b7b18e74252c5 lmdb-default.patch
-56119ecf73fc7b8f3b8e206f2eca05dab1fb0752d9c37e804faebe5fcfa7feca49b8da871ffc9c7f6a247107fef854e09eaf72fc55cea3ca02960db3f8b13c95 postfix-redis.patch
-717d65aa7c3d12e0a269693ec460a3ed1dcac5709b64ba1a467d64f45c32e9b140d360673a1e38fe1d4182b8422c4a7a2c9df00f86bf6d9c12601b32db4ee6a1 dict_redis.c
-bc8888f1741adaea0217a1debee990c28970a207f1790fa1921579d4c925cf56bf7efd438dee743e8c043e73d7c8f4928d5cd98bc3b273c55ba17ccceaf14987 dict_redis.h
"