aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-django-widget-tweaks
diff options
context:
space:
mode:
Diffstat (limited to 'main/py-django-widget-tweaks')
-rw-r--r--main/py-django-widget-tweaks/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/py-django-widget-tweaks/APKBUILD b/main/py-django-widget-tweaks/APKBUILD
new file mode 100644
index 00000000000..41edc63b1ce
--- /dev/null
+++ b/main/py-django-widget-tweaks/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+pkgname=py-django-widget-tweaks
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Tweak the form field rendering in templates, not in python-level form definitions"
+url=https://github.com/kmike/django-widget-tweaks
+arch=noarch
+license=MIT
+depends=py-django
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/d/django-widget-tweaks/django-widget-tweaks-$pkgver.tar.gz
+
+_builddir=$srcdir/django-widget-tweaks-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ ./setup.py install --root "$pkgdir"
+}
+
+md5sums="2ecbb8002e3c178ba0e6d2fe4a9e5798 django-widget-tweaks-1.4.1.tar.gz"
+sha256sums="0baee0b905286fde028fdbd0dd1d985d4656dab472b0fd4ca4cd556ee38a047e django-widget-tweaks-1.4.1.tar.gz"
+sha512sums="699e8ad8fb44355e07e560b698429d8b242e933bbb690cce182b85fce65cdba0ac1d2a28bc723a24db1954d690b35d31b99c39fc9779fd3018869896effba645 django-widget-tweaks-1.4.1.tar.gz"