aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-xml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py-xml/APKBUILD')
-rw-r--r--main/py-xml/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/py-xml/APKBUILD b/main/py-xml/APKBUILD
index 401efaa5a7a..16917193b6e 100644
--- a/main/py-xml/APKBUILD
+++ b/main/py-xml/APKBUILD
@@ -11,18 +11,21 @@ makedepends="python-dev"
source="http://downloads.sourceforge.net/sourceforge/pyxml/PyXML-$pkgver.tar.gz
fix-python2.6.patch"
-_builddir="$srcdir"/PyXML-$pkgver
+builddir="$srcdir"/PyXML-$pkgver
build() {
- cd "$_builddir"
- patch -Np1 -i "$srcdir/fix-python2.6.patch" || return 1
+ cd "$builddir"
python setup.py build || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
install -D -m644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" || return 1
}
md5sums="1f7655050cebbb664db976405fdba209 PyXML-0.8.4.tar.gz
4b652e0c866e3cca7e2386e8e383d5ba fix-python2.6.patch"
+sha256sums="9fab66f9584fb8e67aebd8745a5c97bf1c5a2e2e461adf68862bcec64e448c13 PyXML-0.8.4.tar.gz
+163dd62e1b495c4918b568295e6da95c06ac6fb9982f28b80998b1f3fed97194 fix-python2.6.patch"
+sha512sums="68d9802a58b8ce90d668d2ba659136dc5377e224fdb837284fdcaf640f28b3bb400bf485d602689905d56121b9ffaa7f7758b4a2f262d1321c8b9890952c8a1e PyXML-0.8.4.tar.gz
+c943212f8c12cc9b1d500b30894d9f9b0b3acc883ffbc4c3d8db9da56fdabc22a8d653c2515ae453c90c53400e0b4dfaf0b24a1f5116453f567ea89f9d671706 fix-python2.6.patch"