aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-alabaster/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-alabaster/APKBUILD')
-rw-r--r--main/py3-alabaster/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/main/py3-alabaster/APKBUILD b/main/py3-alabaster/APKBUILD
index ab0b546f590..869471ccd99 100644
--- a/main/py3-alabaster/APKBUILD
+++ b/main/py3-alabaster/APKBUILD
@@ -2,26 +2,30 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-alabaster
_pkgname=alabaster
-pkgver=0.7.12
-pkgrel=4
-pkgdesc="Modified Kr Sphinx doc theme"
-url="https://github.com/bitprophet/alabaster"
+pkgver=0.7.16
+pkgrel=0
+pkgdesc="Lightweight, configurable Sphinx theme"
+url="https://alabaster.readthedocs.io/en/latest/"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
-makedepends="py3-setuptools"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/bitprophet/$_pkgname/archive/$pkgver.tar.gz"
+makedepends="py3-flit-core py3-gpep517"
+subpackages="$pkgname-pyc"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/sphinx-doc/alabaster/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-alabaster" # Backwards compatibility
provides="py-alabaster=$pkgver-r$pkgrel" # Backwards compatibility
+options="!check"
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="e6bcfbf02ee83eaa33c71b8a3d1cb767cc4bfc2b95f79a86a59292988e28abea32a7d55be9a9cdfa9592efed5de3afd7604f9bb65e1f90ba5f377ec54d540f9e alabaster-0.7.12.tar.gz"
+sha512sums="
+a2a38a4923e47a89310de0128a8be3b1304b548810ef9f04bc2b4db0664f752e8db85c32bcdaec1565c9310753ab1d2b4a69789bf75ea5ba2d1ff60bd04a20d2 alabaster-0.7.16.tar.gz
+"