aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-dbus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-dbus/APKBUILD')
-rw-r--r--main/py3-dbus/APKBUILD40
1 files changed, 18 insertions, 22 deletions
diff --git a/main/py3-dbus/APKBUILD b/main/py3-dbus/APKBUILD
index 8d57e9fb747..6a744492b60 100644
--- a/main/py3-dbus/APKBUILD
+++ b/main/py3-dbus/APKBUILD
@@ -2,43 +2,39 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-dbus
_pkgname=dbus-python
-pkgver=1.2.16
-pkgrel=2
+pkgver=1.3.2
+pkgrel=5
pkgdesc="Python3 bindings for DBUS"
-url="http://www.freedesktop.org/wiki/Software/DBusBindings"
+url="https://www.freedesktop.org/wiki/Software/DBusBindings"
arch="all"
license="MIT"
depends="python3"
depends_dev="py3-dbus"
-makedepends="dbus-glib-dev python3-dev py3-sphinx py3-sphinx_rtd_theme"
+makedepends="dbus-glib-dev python3-dev meson"
checkdepends="bash dbus py3-gobject3 py3-tappy"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev"
source="https://dbus.freedesktop.org/releases/dbus-python/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
-replaces="py-dbus" # Backwards compatibility
-provides="py-dbus=$pkgver-r$pkgrel" # Backwards compatibility
-
-
build() {
- python3 setup.py build
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --enable-documentation \
- PYTHON_VERSION=3
- make
+ abuild-meson \
+ -Dtests="$(want_check && echo true || echo false)" \
+ . output
+ meson compile -C output
}
check() {
- make check
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- python3 setup.py install --skip-build --prefix=/usr --root="$pkgdir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ local pyminor="$(python3 -c 'import sys; print("%i" % sys.version_info.minor)')"
+
+ mv dbus_python.egg-info/ "$pkgdir"/usr/lib/python3.$pyminor/site-packages/dbus_python-$pkgver-py3.$pyminor.egg-info/
}
-sha512sums="e76c00c5fd3fe6884e4c24f258987fd3b80d21bd4e0f96aa8fda152078a860b62321324f6efcbfe7226d5ab2521a14b5bda7cf2468d2cae5f376c124a71aa05c dbus-python-1.2.16.tar.gz"
+sha512sums="
+9b2885c9c2914142c72487f766b1cdd28a255d9f5a87eaf8f4eb420c6e096a77f210ac5a4fac9843c6531974872880cc28b7e45940e198856e984dcc0715519a dbus-python-1.3.2.tar.gz
+"