aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-distlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-distlib/APKBUILD')
-rw-r--r--main/py3-distlib/APKBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/main/py3-distlib/APKBUILD b/main/py3-distlib/APKBUILD
index e95b94c71d7..69fdf1238cc 100644
--- a/main/py3-distlib/APKBUILD
+++ b/main/py3-distlib/APKBUILD
@@ -1,35 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Peter Shkenev <santurysim@gmail.com>
pkgname=py3-distlib
-pkgver=0.3.3
-pkgrel=0
+pkgver=0.3.8
+pkgrel=1
pkgdesc="Distribution utilities"
-options="!check" # 1 test in tests/test_locator.py fails
-url="https://bitbucket.org/pypa/distlib"
+url="https://github.com/pypa/distlib"
arch="noarch"
license="PSF-2.0"
depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/d/distlib/distlib-$pkgver.zip"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/distlib/archive/refs/tags/$pkgver.tar.gz
+ 10-remove-funky-test.patch
+ "
builddir="$srcdir/distlib-$pkgver"
-prepare() {
- default_prepare
- rm distlib/*.exe
-}
-
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONHASHSEED=0 python3 setup.py test
+ PYTHONHASHSEED=0 python3 -m unittest discover tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/distlib*.whl
+
+ rm "$pkgdir"/usr/lib/python3*/site-packages/distlib/*.exe
}
sha512sums="
-834ed7314b2c3aecaaa833a275aac9ae72feb27e62c4e712b30bb5ac526bd38d18756d51ca8c95015953dac7f0cfd7e60382c0a7bdf330d8a01602ccb7344f0d distlib-0.3.3.zip
+98dc6459f54783598aad8ee3b8d80c0092a5d08d4272ad212faeef5e30cf9029b718231681f39d26e48588bb676bae7919f1431ddb51eb3917725f99a5c90457 py3-distlib-0.3.8.tar.gz
+c77d21ec087abe6dbd80bcfc20f3b26d881ff7f42e2ba37185fe6315934afda5be23eed7cc522ecf01d696ba031ed83a2a43e87cd7be6ee7a7963eaa95afebe7 10-remove-funky-test.patch
"