aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-elementpath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-elementpath/APKBUILD')
-rw-r--r--main/py3-elementpath/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/main/py3-elementpath/APKBUILD b/main/py3-elementpath/APKBUILD
new file mode 100644
index 00000000000..09750158a9f
--- /dev/null
+++ b/main/py3-elementpath/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Aiden Grossman <agrossman154@yahoo.com>
+# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
+pkgname=py3-elementpath
+pkgver=4.1.5
+pkgrel=2
+pkgdesc="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+url="https://github.com/sissaschool/elementpath"
+arch="noarch"
+license="MIT"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-lxml"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sissaschool/elementpath/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/elementpath-$pkgver/"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # first four disabled tests fails on locale differences
+ # Rest of the tests need more investigation, started with upgrade to 4.1.0
+ .testenv/bin/python3 -m pytest \
+ --ignore=tests/test_sequence_types.py \
+ --deselect tests/test_xpath2_functions.py::XPath2FunctionsTest::test_compare_function \
+ --deselect tests/test_xpath30.py::XPath30FunctionsTest::test_compare_function \
+ --deselect tests/test_xpath31.py::XPath31FunctionsTest::test_compare_function \
+ --deselect tests/test_collations.py::CollationsTest::test_context_activation \
+ --deselect tests/test_xpath2_functions.py::LxmlXPath2FunctionsTest::test_compare_function \
+ --deselect tests/test_xpath30.py::LxmlXPath30FunctionsTest::test_compare_function \
+ --deselect tests/test_xpath31.py::LxmlXPath31FunctionsTest::test_compare_function \
+ --deselect tests/test_validators.py::ValidatorsTest::test_validate_analyzed_string \
+ --deselect tests/test_validators.py::ValidatorsTest::test_validate_json_to_xml
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+29989210238aacdf111cba49d09488254a6bd479b381e57699c8d1eca8ec21badf666744402aae891210142ce56cfce66b55bf372e5de8b7b48a45bed46b0cf3 py3-elementpath-4.1.5.tar.gz
+"