aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-extras/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-extras/APKBUILD')
-rw-r--r--main/py3-extras/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/main/py3-extras/APKBUILD b/main/py3-extras/APKBUILD
index 25561717983..5056db7f198 100644
--- a/main/py3-extras/APKBUILD
+++ b/main/py3-extras/APKBUILD
@@ -3,28 +3,38 @@
pkgname=py3-extras
_pkgname=extras
pkgver=1.0.0
-pkgrel=5
+pkgrel=10
pkgdesc="Useful extra bits for Python - things that shold be in the standard library"
-url="https://pypi.python.org/pypi/extras/"
+url="https://pypi.org/project/extras/"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-testtools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-extras" # Backwards Compatibility
provides="py-extras=$pkgver-r$pkgrel" # Backwards Compatibility
+options="!check" # py3-testtools depends on this
-check() {
- python3 setup.py check
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-build() {
- python3 setup.py build
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="510c796628f28db90bb96c7c9ba5fc9b2b950d2968e219efe67f3899bbe7ef68fe5de1494f8fd640f13a1ccd329e7dac9cd38aa965ab1e07c4cd287c04da50fb extras-1.0.0.tar.gz"
+sha512sums="
+510c796628f28db90bb96c7c9ba5fc9b2b950d2968e219efe67f3899bbe7ef68fe5de1494f8fd640f13a1ccd329e7dac9cd38aa965ab1e07c4cd287c04da50fb extras-1.0.0.tar.gz
+"