aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-filelock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-filelock/APKBUILD')
-rw-r--r--main/py3-filelock/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/main/py3-filelock/APKBUILD b/main/py3-filelock/APKBUILD
deleted file mode 100644
index a51668bcd93..00000000000
--- a/main/py3-filelock/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
-# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
-pkgname=py3-filelock
-_pkgname=filelock
-pkgver=3.0.12
-pkgrel=1
-pkgdesc="A platform independent file lock for Python3"
-url="https://github.com/benediktschmitt/py-filelock"
-arch="noarch"
-license="Unlicense"
-depends="python3"
-checkdepends="py3-pytest"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-replaces="py-filelock" # Backwards compatibility
-provides="py-filelock=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python3 -m pytest -xvv test.py
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="09b8b16c12a60044a259a5d644bc8066660871104a7f4cd431431173d475b9f15744adfb8d86ec8cda69f2a1b52bd14cb8a066d70fa5e49c449bc5ee702ec2a0 filelock-3.0.12.tar.gz"