aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-hypothesis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-hypothesis/APKBUILD')
-rw-r--r--main/py3-hypothesis/APKBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/main/py3-hypothesis/APKBUILD b/main/py3-hypothesis/APKBUILD
deleted file mode 100644
index 25335c08107..00000000000
--- a/main/py3-hypothesis/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Drew DeVault <sir@cmpwn.com>
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Michał Polański <michal@polanski.me>
-pkgname=py3-hypothesis
-pkgver=6.28.1
-pkgrel=0
-pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
-options="!check"
-url="https://hypothesis.works/"
-arch="noarch"
-license="MPL-2.0"
-depends="py3-attrs py3-sortedcontainers"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-coverage py3-tz py3-numpy py3-dateutil py3-pexpect"
-source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz
- "
-builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
-
-replaces="py-hypothesis" # Backwards compatibility
-provides="py-hypothesis=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- # In python3 mock is actually unittest.mock
- sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_regressions.py
- sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_reflection.py
-
- rm -rf tests/lark tests/dpcontracts tests/pandas
- PYTHONPATH="$PWD/build/lib" pytest-3 -v -k "not test_healthcheck_traceback_is_hidden"
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-4402e7d6030ef79214d9d4b83d165788a3a45bc733aeefb7d70a85fb3d542dc1619943d19cbf7abc3902bf23eecb61a369915bee333abd3347927522ae9ed01d py-hypothesis-6.28.1.tar.gz
-"