aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-hypothesis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-hypothesis/APKBUILD')
-rw-r--r--main/py3-hypothesis/APKBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/main/py3-hypothesis/APKBUILD b/main/py3-hypothesis/APKBUILD
deleted file mode 100644
index 8a05046c90a..00000000000
--- a/main/py3-hypothesis/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Drew DeVault <sir@cmpwn.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
-pkgname=py3-hypothesis
-pkgver=5.41.4
-pkgrel=0
-pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
-options="!check"
-url="https://hypothesis.works/"
-arch="noarch"
-license="MPL-2.0"
-depends="py3-attrs py3-sortedcontainers"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-coverage py3-tz py3-numpy py3-dateutil py3-pexpect"
-source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz
- "
-builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
-
-replaces="py-hypothesis" # Backwards compatibility
-provides="py-hypothesis=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-check() {
- # In python3 mock is actually unittest.mock
- sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_regressions.py
- sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_reflection.py
-
- rm -rf tests/lark tests/dpcontracts tests/pandas
- PYTHONPATH="$PWD/build/lib" pytest-3 -v -k "not test_healthcheck_traceback_is_hidden"
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="215f2e4479eca10d8ca590ffe0623f8994c7061fddabfe2737d0f3bba2f403042ad8e75730361417a1c9c32d3e261c8daa84032f6963ef6526e6b0067a156658 py-hypothesis-5.41.4.tar.gz"