aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-installer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-installer/APKBUILD')
-rw-r--r--main/py3-installer/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/main/py3-installer/APKBUILD b/main/py3-installer/APKBUILD
index 1bbd91bbdcf..e90fbb381fb 100644
--- a/main/py3-installer/APKBUILD
+++ b/main/py3-installer/APKBUILD
@@ -1,35 +1,40 @@
# Contributor: Sean McAvoy <seanmcavoy@gmail.com>
# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
pkgname=py3-installer
-pkgver=0.5.1
-pkgrel=1
+pkgver=0.7.0
+pkgrel=2
pkgdesc="low-level library for installing from a Python wheel distribution"
url="https://github.com/pypa/installer"
arch="noarch"
license="MIT"
depends="python3"
checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/i/installer/installer-$pkgver.tar.gz
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/py3/i/installer/installer-$pkgver-py3-none-any.whl
default-bytecode-levels.patch
"
-builddir="$srcdir/installer-$pkgver"
# checkdepends causes weird circular behaviour,
# because py3-pytest depends on this down the chain
options="!check"
-build() {
- python3 setup.py build
-}
+unpack() {
+ default_unpack
-check() {
- PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
+ # we have to use the wheel because py3-installer is the base to be able to
+ # install generated wheels, so we don't have it when building it itself
+ mkdir -p "$builddir"
+ unzip -d "$builddir" "$srcdir"/installer-$pkgver-py3-none-any.whl
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
+ mkdir -p "$pkgdir/$sitedir"
+ cp -a installer* "$pkgdir/$sitedir"
+
+ python3 -m compileall "$pkgdir/$sitedir"
}
sha512sums="
-fcdbd0001c8b87cb73f49453c7be30c52579eec6d9134b8e9406aab59bfdf7899360fbbe9cc37c9db54356e5408322aea80307d73231b136918f7d2af013afd1 installer-0.5.1.tar.gz
-fa5046b07cd4dcb04d3112c6a24ad613b77213c98e2e8b33994cc8f8fe4acae1460d4efd9610a6d9b61dd896fb02c18cd7d0b8890c4d174fb52e9d04dcbef95d default-bytecode-levels.patch
+8e10013521238ef8fb2f5ab4bd00f6154c05046011cad8824d96b7cdc4ed235b87e534d1e163a47a11dbfb5bb3cf19d9a2ea3edd1e9c9ce5fbc9a375010c36dc installer-0.7.0-py3-none-any.whl
+d389b34e2de943823978b1a8a782a6e14a50b577870e71a95a4482ffbbf3a79217e0aa00673166f5e75d6ce9c07ee4d029d7baa8b37c0914a2429e2e04df4dd4 default-bytecode-levels.patch
"