aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-packaging/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-packaging/APKBUILD')
-rw-r--r--main/py3-packaging/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/main/py3-packaging/APKBUILD b/main/py3-packaging/APKBUILD
index 273d1783f67..991aa7c2f96 100644
--- a/main/py3-packaging/APKBUILD
+++ b/main/py3-packaging/APKBUILD
@@ -1,17 +1,19 @@
# Contributor: Breno Leitao <breno.leitao@gmail.com>
-# Maintainer:
+# Maintainer: Peter Shkenev <santurysim@gmail.com>
pkgname=py3-packaging
_pkgname=packaging
-pkgver=21.3
+pkgver=24.0
pkgrel=0
pkgdesc="Core utilities for Python3 packages"
options="!check" # Requires py3-pytest which requires py3-setuptools
-url="https://pypi.python.org/pypi/packaging"
+url="https://pypi.org/project/packaging"
arch="noarch"
license="Apache-2.0 AND BSD-2-Clause"
-depends="python3 py3-parsing py3-six"
+depends="python3 py3-parsing"
+makedepends="py3-flit-core py3-gpep517"
# disable check to break circular dep with py3-setuptools
checkdepends="py3-pytest py3-pretend"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/packaging/packaging-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -21,24 +23,25 @@ provides="py-packaging=$pkgver-r$pkgrel" # Backwards compatibility
[ "$CARCH" = s390x ] && options="$options !check" # fails a lot
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
check() {
- PYTHONPATH="$PWD/build/lib" python3 -m pytest \
- --ignore=tests/test_manylinux.py \
- --ignore=tests/test_markers.py \
- --ignore=tests/test_specifiers.py \
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
--ignore=tests/test_tags.py \
- --ignore=tests/test_version.py
- # tests that require https://pypi.org/project/pretend/ are disabled
- # above because py3-pretend hasn't been packaged for Alpine Linux
+ --deselect \
+ tests/test_manylinux.py::test_is_manylinux_compatible_old
}
sha512sums="
-2e3aa276a4229ac7dc0654d586799473ced9761a83aa4159660d37ae1a2a8f30e987248dd0e260e2834106b589f259a57ce9936eef0dcc3c430a99ac6b663e05 packaging-21.3.tar.gz
+b6af704f93bcb7611a06eb2bfa94d8dc4bb1e5e9898af7c0eb85e67cf1ebdb858e272ca18019be4daaa43ac3f73b1cb2e690d8b50a4252380a2dc9f2d0e03a58 packaging-24.0.tar.gz
"