aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-packaging/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-packaging/APKBUILD')
-rw-r--r--main/py3-packaging/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/main/py3-packaging/APKBUILD b/main/py3-packaging/APKBUILD
index 48705b4e437..53cc9725a3b 100644
--- a/main/py3-packaging/APKBUILD
+++ b/main/py3-packaging/APKBUILD
@@ -2,21 +2,24 @@
# Maintainer:
pkgname=py3-packaging
_pkgname=packaging
-pkgver=20.9
-pkgrel=1
+pkgver=21.2
+pkgrel=0
pkgdesc="Core utilities for Python3 packages"
-options="!check" # Requires py3-pytest which requires py3-setuptools
+#options="!check" # Requires py3-pytest which requires py3-setuptools
url="https://pypi.python.org/pypi/packaging"
arch="noarch"
license="Apache-2.0 AND BSD-2-Clause"
depends="python3 py3-parsing py3-six"
-#checkdepends="py3-pytest" # disable check to breake circular dep with py3-setuptools
+# disable check to break circular dep with py3-setuptools
+checkdepends="py3-pytest py3-pretend"
source="https://files.pythonhosted.org/packages/source/p/packaging/packaging-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-packaging" # Backwards compatibility
provides="py-packaging=$pkgver-r$pkgrel" # Backwards compatibility
+[ "$CARCH" = s390x ] && options="$options !check" # fails a lot
+
build() {
python3 setup.py build
}
@@ -27,6 +30,7 @@ package() {
check() {
PYTHONPATH="$PWD/build/lib" python3 -m pytest \
+ --ignore=tests/test_manylinux.py \
--ignore=tests/test_markers.py \
--ignore=tests/test_specifiers.py \
--ignore=tests/test_tags.py \
@@ -35,4 +39,6 @@ check() {
# above because py3-pretend hasn't been packaged for Alpine Linux
}
-sha512sums="229b729aa9be7730509b7036dce0ca0750103fb7e2cd45d51f0eeaf2a4731605d63d11e11c10c7c481e228faa5e860c2c8f7bc6bee3190cafd72c22d7b3db264 packaging-20.9.tar.gz"
+sha512sums="
+21bdab5e529ee47a9a16d2863650120062011469e035e869fb6526ebaf61a6e8167e6a2278b74db8c15fcb9a8bc70a11c3ebe1e7ab1d677dc09ee67456d0aa1a packaging-21.2.tar.gz
+"