aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-parsing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-parsing/APKBUILD')
-rw-r--r--main/py3-parsing/APKBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/main/py3-parsing/APKBUILD b/main/py3-parsing/APKBUILD
index 95aafdb13cb..a1b61ae1eb4 100644
--- a/main/py3-parsing/APKBUILD
+++ b/main/py3-parsing/APKBUILD
@@ -2,31 +2,37 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-parsing
_pkgname=pyparsing
-pkgver=2.4.7
-pkgrel=0
-pkgdesc="An object-oriented approach to text processing"
-url="http://pyparsing.wikispaces.com/"
+pkgver=3.1.2
+pkgrel=1
+pkgdesc="Object-oriented approach to text processing"
+url="https://github.com/pyparsing/pyparsing"
arch="noarch"
license="MIT"
depends="python3"
+makedepends="py3-flit-core py3-gpep517"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+options="!check" # too low level, and needs unpackaged railroad
replaces="py-parsing" # Backwards compatibility
provides="py-parsing=$pkgver-r$pkgrel" # Backwards compatibility
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
check() {
python3 -m unittest
}
package() {
- # Can't use setuptools since setuptools depends on this
- mkdir -p "$pkgdir"/usr/lib/python3.8/site-packages
-
- cp -rv $_pkgname.egg-info \
- "$pkgdir"/usr/lib/python3.8/site-packages/$_pkgname-$pkgver-py3.8.egg-info
- cp -rv pyparsing.py "$pkgdir"/usr/lib/python3.8/site-packages/
-
- python3 -m compileall -f -q "$pkgdir"/usr/lib/python3.8/site-packages/*.py
+ python3 -m installer -d "$pkgdir" \
+ .dist/pyparsing-$pkgver-py3-none-any.whl
}
-sha512sums="0b9f8f18907f65cb3af1b48ed57989e183f28d71646f2b2f820e772476f596ca15ee1a689f3042f18458206457f4683d10daa6e73dfd3ae82d5e4405882f9dd2 pyparsing-2.4.7.tar.gz"
+
+sha512sums="
+1134949f3576edbec4438eefe952eb5cc6e734fb060905d714b6a77f71e90d364b01345df5e7b8fb5ffa798c530be9c65f6d152b3f591cba787660c4dd8894d2 pyparsing-3.1.2.tar.gz
+"