aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-parsing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-parsing/APKBUILD')
-rw-r--r--main/py3-parsing/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/py3-parsing/APKBUILD b/main/py3-parsing/APKBUILD
new file mode 100644
index 00000000000..a1b61ae1eb4
--- /dev/null
+++ b/main/py3-parsing/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-parsing
+_pkgname=pyparsing
+pkgver=3.1.2
+pkgrel=1
+pkgdesc="Object-oriented approach to text processing"
+url="https://github.com/pyparsing/pyparsing"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-flit-core py3-gpep517"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+options="!check" # too low level, and needs unpackaged railroad
+
+replaces="py-parsing" # Backwards compatibility
+provides="py-parsing=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m unittest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/pyparsing-$pkgver-py3-none-any.whl
+}
+
+sha512sums="
+1134949f3576edbec4438eefe952eb5cc6e734fb060905d714b6a77f71e90d364b01345df5e7b8fb5ffa798c530be9c65f6d152b3f591cba787660c4dd8894d2 pyparsing-3.1.2.tar.gz
+"