aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-purl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-purl/APKBUILD')
-rw-r--r--main/py3-purl/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/main/py3-purl/APKBUILD b/main/py3-purl/APKBUILD
deleted file mode 100644
index 8ed54c7c62b..00000000000
--- a/main/py3-purl/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py3-purl
-_pkgname=purl
-pkgver=1.5
-pkgrel=2
-pkgdesc="An immutable Python3 URL class for easy URL-building and manipulation"
-url="https://github.com/codeinthehole/purl"
-arch="noarch"
-license="MIT"
-depends="py3-six"
-# Tests are not included in the tarball
-options="!check"
-depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-replaces="py-purl" # Backwards compatibility
-provides="py-purl=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="e7ef3dbe51117c2807a5cd472967d90c9f16fc1090f2edcaf3c4fe0bbc95b8ef8d612d5ca98401caf5a94c5b0335949ac0ac490bc694e571ff516b7bf53fae32 purl-1.5.tar.gz"