aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-pytest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-pytest/APKBUILD')
-rw-r--r--main/py3-pytest/APKBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/main/py3-pytest/APKBUILD b/main/py3-pytest/APKBUILD
index 155aa1e9cda..eae345a0fde 100644
--- a/main/py3-pytest/APKBUILD
+++ b/main/py3-pytest/APKBUILD
@@ -1,19 +1,25 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pytest
-pkgver=6.2.5
-pkgrel=1
+pkgver=8.1.1
+pkgrel=0
pkgdesc="Python3 testing library"
url="https://docs.pytest.org/en/latest/"
arch="noarch"
license="MIT"
-depends="py3-atomicwrites py3-attrs py3-more-itertools py3-iniconfig py3-pluggy py3-py py3-six py3-wcwidth
- py3-packaging py3-toml"
-makedepends="py3-setuptools"
+depends="
+ py3-iniconfig
+ py3-packaging
+ py3-pluggy
+ py3-py
+ "
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="bash py3-hypothesis py3-virtualenv py3-xmlschema"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pytest/pytest-$pkgver.tar.gz
- 0001-remove-setuptools_scm.patch
"
builddir="$srcdir/pytest-$pkgver"
+options="!check" # causes bootstrapping issues because of checkdepends
replaces="pytest" # Backwards compatibility
provides="pytest=$pkgver-r$pkgrel" # Backwards compatibility
@@ -25,11 +31,16 @@ prepare() {
}
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/pytest*.whl
+
+ test-env/bin/python3 -m pytest
}
package() {
@@ -39,10 +50,10 @@ package() {
ln -s $name-3 "$pkgdir"/usr/bin/$name
done
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest*.whl
}
sha512sums="
-7624563a9d967da4cbf82cfff90bae8c0cca07b32e291dc7c5efa787725ed1a255edd066bf0d5fbd89b8cbed8cf5b619fe7c7017f44a7f8a014e3310c06bdbf9 pytest-6.2.5.tar.gz
-c1a08e07a98366dbbc8ef01cbfcb6a087ad6e9813a82e0893492d9312f5dde2dcfeaf5a9554b17dc10139b5af5949eacbdfc50d29319cbb284e28bd8e5770b56 0001-remove-setuptools_scm.patch
+f1a9f69cd4eca3ab36c36bc666bf70b099125ed6e17b89d13554c3f13b100d05abfd0b35516660d00ca4fb9eca81164ab02bc8f7a9a8d90fd4302bf399cd88c0 pytest-8.1.1.tar.gz
"