aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-pytest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-pytest/APKBUILD')
-rw-r--r--main/py3-pytest/APKBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/main/py3-pytest/APKBUILD b/main/py3-pytest/APKBUILD
index cfaa4e76e82..58c22ba9062 100644
--- a/main/py3-pytest/APKBUILD
+++ b/main/py3-pytest/APKBUILD
@@ -1,30 +1,22 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pytest
-pkgver=7.1.2
+pkgver=8.1.1
pkgrel=1
pkgdesc="Python3 testing library"
url="https://docs.pytest.org/en/latest/"
arch="noarch"
license="MIT"
depends="
- py3-atomicwrites
- py3-attrs
py3-iniconfig
- py3-more-itertools
py3-packaging
py3-pluggy
py3-py
- py3-pygments
- py3-six
- py3-tomli
- py3-wcwidth
- python3
"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="bash py3-hypothesis py3-virtualenv py3-xmlschema"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pytest/pytest-$pkgver.tar.gz
- 0001-remove-setuptools_scm.patch
"
builddir="$srcdir/pytest-$pkgver"
options="!check" # causes bootstrapping issues because of checkdepends
@@ -39,12 +31,14 @@ prepare() {
}
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m venv --system-site-packages test-env
- test-env/bin/python3 setup.py install
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/pytest*.whl
test-env/bin/python3 -m pytest
}
@@ -56,10 +50,10 @@ package() {
ln -s $name-3 "$pkgdir"/usr/bin/$name
done
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest*.whl
}
sha512sums="
-e61c9b0a8fc053626da307d6bac1f5caab451c4948ef7c7f2e2f991c3433a55f81ec0d9412fca646c02f22e695c71e873ee48fc0ab0aad337ce01b70628df494 pytest-7.1.2.tar.gz
-3e8f2ed789b668371a51c25bd3ff1c31132fc8a1e415437034023cd2537d1a27d759058156664730a8c381c2a2a536813b739b1d8fbb2534c6d8ed374629e979 0001-remove-setuptools_scm.patch
+f1a9f69cd4eca3ab36c36bc666bf70b099125ed6e17b89d13554c3f13b100d05abfd0b35516660d00ca4fb9eca81164ab02bc8f7a9a8d90fd4302bf399cd88c0 pytest-8.1.1.tar.gz
"