aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-pytest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-pytest/APKBUILD')
-rw-r--r--main/py3-pytest/APKBUILD41
1 files changed, 32 insertions, 9 deletions
diff --git a/main/py3-pytest/APKBUILD b/main/py3-pytest/APKBUILD
index b83c36a89d2..58c22ba9062 100644
--- a/main/py3-pytest/APKBUILD
+++ b/main/py3-pytest/APKBUILD
@@ -1,26 +1,46 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pytest
-pkgver=5.4.3
-pkgrel=0
+pkgver=8.1.1
+pkgrel=1
pkgdesc="Python3 testing library"
url="https://docs.pytest.org/en/latest/"
arch="noarch"
license="MIT"
-depends="py3-atomicwrites py3-py py3-six py3-attrs py3-more-itertools py3-pluggy py3-wcwidth
- py3-setuptools py3-packaging"
-source="https://files.pythonhosted.org/packages/source/p/pytest/pytest-$pkgver.tar.gz"
+depends="
+ py3-iniconfig
+ py3-packaging
+ py3-pluggy
+ py3-py
+ "
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="bash py3-hypothesis py3-virtualenv py3-xmlschema"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/pytest/pytest-$pkgver.tar.gz
+ "
builddir="$srcdir/pytest-$pkgver"
+options="!check" # causes bootstrapping issues because of checkdepends
replaces="pytest" # Backwards compatibility
provides="pytest=$pkgver-r$pkgrel" # Backwards compatibility
+prepare() {
+ default_prepare
+
+ sed -e "/^\[metadata\]/a version = $pkgver" -i setup.cfg
+}
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/pytest*.whl
+
+ test-env/bin/python3 -m pytest
}
package() {
@@ -30,7 +50,10 @@ package() {
ln -s $name-3 "$pkgdir"/usr/bin/$name
done
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest*.whl
}
-sha512sums="0a07d4f4f791969c6f21961a0ba0f8c6670e5870c6cc1cebf93766587bb9cb3e10db8e57f0bd33dd22b275f3aad7aa674949f124ac80e0ccca64e35be4beee4e pytest-5.4.3.tar.gz"
+sha512sums="
+f1a9f69cd4eca3ab36c36bc666bf70b099125ed6e17b89d13554c3f13b100d05abfd0b35516660d00ca4fb9eca81164ab02bc8f7a9a8d90fd4302bf399cd88c0 pytest-8.1.1.tar.gz
+"