aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-requests/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-requests/APKBUILD')
-rw-r--r--main/py3-requests/APKBUILD37
1 files changed, 21 insertions, 16 deletions
diff --git a/main/py3-requests/APKBUILD b/main/py3-requests/APKBUILD
index 6e23330071a..893fb80d308 100644
--- a/main/py3-requests/APKBUILD
+++ b/main/py3-requests/APKBUILD
@@ -1,35 +1,40 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-requests
-_pkgname=requests
-pkgver=2.25.1
-pkgrel=4
+pkgver=2.31.0
+pkgrel=2
pkgdesc="HTTP request library for Python3"
-url="http://www.python-requests.org/"
+url="https://requests.readthedocs.io/"
arch="noarch"
license="Apache-2.0"
# Requirements for tests are not available in main
options="!check"
-depends="python3 py3-chardet py3-idna py3-urllib3 py3-certifi"
-makedepends="py3-setuptools"
-source="
- https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- 0002-allow-idna-3.patch
-"
-builddir="$srcdir/$_pkgname-$pkgver"
+depends="
+ py3-certifi
+ py3-charset-normalizer
+ py3-idna
+ py3-urllib3
+ python3
+ "
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/r/requests/requests-$pkgver.tar.gz"
+builddir="$srcdir/requests-$pkgver"
replaces="py-requests" # Backwards compatibility
provides="py-requests=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-ca6b0a257b448a999cade0ae173c29cddc9cfffb319d16fc3d051d3e1cd77161536e3cab279b3cba59c60d29d7864a9281c1fa1f689ce48d3bce2ca9f1cd8d45 requests-2.25.1.tar.gz
-28ea1bdfd897833d2563474979c0b6f2965d61c5cc29768e60592f4d36c7df6d7fa8408a424f99db332f898fb487c4b7b110884a04f6180d4b73646299d9c019 0002-allow-idna-3.patch
+ce50d64973752f4cf7f7c7c91401669854b55c66d7465bea3689772fae8a6b646cf6720d84a2984bbe6fd78fc8b9ce0aa377f291fb6d7c20c7c2a4be8193acdd requests-2.31.0.tar.gz
"