aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-requests/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-requests/APKBUILD')
-rw-r--r--main/py3-requests/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/main/py3-requests/APKBUILD b/main/py3-requests/APKBUILD
index 58b4e097cb5..e5f1786ab2d 100644
--- a/main/py3-requests/APKBUILD
+++ b/main/py3-requests/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-requests
-pkgver=2.27.1
-pkgrel=0
+pkgver=2.31.0
+pkgrel=1
pkgdesc="HTTP request library for Python3"
-url="http://www.python-requests.org/"
+url="https://requests.readthedocs.io/"
arch="noarch"
license="Apache-2.0"
# Requirements for tests are not available in main
@@ -16,7 +16,8 @@ depends="
py3-urllib3
python3
"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/r/requests/requests-$pkgver.tar.gz"
builddir="$srcdir/requests-$pkgver"
@@ -24,13 +25,16 @@ replaces="py-requests" # Backwards compatibility
provides="py-requests=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-e51916abea8125254c5ee72c97e84a73e6981cab09961486873387522d2ce041ee3fe8fa2ff0b9bbe6707eefdc05145e9adcf127bcd999dea127acdfabd5312f requests-2.27.1.tar.gz
+ce50d64973752f4cf7f7c7c91401669854b55c66d7465bea3689772fae8a6b646cf6720d84a2984bbe6fd78fc8b9ce0aa377f291fb6d7c20c7c2a4be8193acdd requests-2.31.0.tar.gz
"