aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-six/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-six/APKBUILD')
-rw-r--r--main/py3-six/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/main/py3-six/APKBUILD b/main/py3-six/APKBUILD
index b384ee56823..94da874f65b 100644
--- a/main/py3-six/APKBUILD
+++ b/main/py3-six/APKBUILD
@@ -1,33 +1,34 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-six
_pkgname=six
pkgver=1.16.0
-pkgrel=0
+pkgrel=9
pkgdesc="Python 2 and 3 compatibility library"
-url="https://pypi.python.org/pypi/six"
+url="https://pypi.org/project/six"
arch="noarch"
license="MIT"
depends="python3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-six" # Backwards compatibility
provides="py-six=$pkgver-r$pkgrel" # Backwards compatibility
-# circular dependency with pytest
-#checkdepends="pytest py3-pytest"
-options="!check"
-
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest -rfsxX
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -rfsxX
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="