aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-sphinx
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-sphinx')
-rw-r--r--main/py3-sphinx/APKBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/main/py3-sphinx/APKBUILD b/main/py3-sphinx/APKBUILD
index bc54229fdd6..2ab562ea724 100644
--- a/main/py3-sphinx/APKBUILD
+++ b/main/py3-sphinx/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-sphinx
-pkgver=3.2.1
-pkgrel=0
-pkgdesc="Python Documentation Generator"
+pkgver=7.2.6
+pkgrel=1
+pkgdesc="Python Documentation Generator"
# checkdepends require 'imagemagick' and 'py3-html5lib' which
# are in community/, 'imagemagick' itself also needs 'librsvg'
# and 'libheif', which bring in 'rust', 'x265' and others, this
# is too much of a burden to put on main/
options="!check"
-url="http://sphinx.pocoo.org/"
+url="https://www.sphinx-doc.org/"
arch="noarch"
license="BSD-2-Clause"
depends="
@@ -17,9 +17,9 @@ depends="
py3-docutils
py3-imagesize
py3-jinja2
+ py3-packaging
py3-pygments
py3-requests
- py3-setuptools
py3-snowballstemmer
py3-alabaster
py3-sphinxcontrib-applehelp
@@ -29,14 +29,18 @@ depends="
py3-sphinxcontrib-serializinghtml
py3-sphinxcontrib-qthelp
"
+makedepends="py3-gpep517 py3-flit-core py3-installer"
# imagemagick is for tests/test_ext_imgconverter.py::test_ext_imgconverter
# which calls the 'convert' binary
checkdepends="py3-pytest py3-funcsigs py3-pluggy imagemagick py3-html5lib"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/sphinx-doc/sphinx/archive/v$pkgver.tar.gz"
builddir="$srcdir/sphinx-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -44,18 +48,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- # TODO: The binaries with the -3 postfix should be
- # considered deprecated and removed in a future release.
- local path; for path in "$pkgdir"/usr/bin/*; do
- mv "$path" "$path"-3
- done
-
- cd "$pkgdir"/usr/bin
- local name; for name in *-3; do
- ln -s -- $name "$pkgdir"/usr/bin/${name%-3}
- done
+ python3 -m installer -d "$pkgdir" \
+ .dist/sphinx-*.whl
}
-sha512sums="e45fc61b3a2812a34b3c876fda7292daac00fb4a985cf4ce243093b4582572fe0a56fad08b518567abfda9fc0f17e6d09f1325f39e219c8ea14ec80998ef0637 py3-sphinx-3.2.1.tar.gz"
+sha512sums="
+204e859318ad5044639f2e682098b07c7cc675b54ba801feeb3322290bfd15316cc15a2cae8fa6a55e6ec6d1e9690790e5402652eb04720bfe96e172f4c8bdbc py3-sphinx-7.2.6.tar.gz
+"