aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-sphinxcontrib-applehelp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-sphinxcontrib-applehelp/APKBUILD')
-rw-r--r--main/py3-sphinxcontrib-applehelp/APKBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/main/py3-sphinxcontrib-applehelp/APKBUILD b/main/py3-sphinxcontrib-applehelp/APKBUILD
index 5ca60740e34..bb242b2b32c 100644
--- a/main/py3-sphinxcontrib-applehelp/APKBUILD
+++ b/main/py3-sphinxcontrib-applehelp/APKBUILD
@@ -1,23 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-sphinxcontrib-applehelp
_pyname=sphinxcontrib-applehelp
-pkgver=1.0.2
-pkgrel=3
+pkgver=1.0.4
+pkgrel=2
pkgdesc="Sphinx applehelp extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-applehelp"
+url="https://pypi.org/project/sphinxcontrib-applehelp"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
+options="!check"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="1325ac83ff15dd28d6f2791caf64e6c08d1dd2f0946dc8891f5c4d8fd062a1e8650c9c39a7459195ef41f3b425f5b8d6c5e277ea85621a36dd870ca5162508da sphinxcontrib-applehelp-1.0.2.tar.gz"
+sha512sums="
+998249b6ac2061d3fefec508396f407af450794d2c08a255c9384e9b1a6222bb83af5421115790cb689ebf5dce1ca846ae3fcb71b60ea6183d79262969a26218 sphinxcontrib-applehelp-1.0.4.tar.gz
+"