aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-sphinxcontrib-devhelp
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-sphinxcontrib-devhelp')
-rw-r--r--main/py3-sphinxcontrib-devhelp/APKBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/main/py3-sphinxcontrib-devhelp/APKBUILD b/main/py3-sphinxcontrib-devhelp/APKBUILD
index 02b582a6bb5..d7686e548d8 100644
--- a/main/py3-sphinxcontrib-devhelp/APKBUILD
+++ b/main/py3-sphinxcontrib-devhelp/APKBUILD
@@ -1,23 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-sphinxcontrib-devhelp
_pyname=sphinxcontrib-devhelp
-pkgver=1.0.2
-pkgrel=0
+pkgver=1.0.5
+pkgrel=1
pkgdesc="Sphinx devhelp extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-devhelp"
+url="https://pypi.org/project/sphinxcontrib-devhelp"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-flit-core py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-sphinx"
+subpackages="$pkgname-pyc"
+source="$_pyname-$pkgver.tar.gz::https://github.com/sphinx-doc/sphinxcontrib-devhelp/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
+options="!check" # py3-sphinx is a circular dep
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="83b46eaf26df3932ea2136cfda1c0fca4fc08ce8bca564845b3efe5bb00d6c8c93991f4edd4913d4ec796e2d85bd2c7265adf28e98f42e8094daeb5ac11a0eb1 sphinxcontrib-devhelp-1.0.2.tar.gz"
+sha512sums="
+d8d6f5429389c100bf81f0030a34713f6d9b0285866b4e912f21e0b490f3a501360f54be2fae9ce82ba025568f9a2f761013a64397289f94bdc06607baeb5bd0 sphinxcontrib-devhelp-1.0.5.tar.gz
+"