aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-sphinxcontrib-htmlhelp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-sphinxcontrib-htmlhelp/APKBUILD')
-rw-r--r--main/py3-sphinxcontrib-htmlhelp/APKBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/main/py3-sphinxcontrib-htmlhelp/APKBUILD b/main/py3-sphinxcontrib-htmlhelp/APKBUILD
index 7c7c7c77a94..2f1e824b834 100644
--- a/main/py3-sphinxcontrib-htmlhelp/APKBUILD
+++ b/main/py3-sphinxcontrib-htmlhelp/APKBUILD
@@ -1,30 +1,40 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-sphinxcontrib-htmlhelp
_pyname=sphinxcontrib-htmlhelp
-pkgver=2.0.0
-pkgrel=2
+pkgver=2.0.1
+pkgrel=3
pkgdesc="Sphinx htmlhelp extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-htmlhelp"
+url="https://pypi.org/project/sphinxcontrib-htmlhelp"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
options="!check" # cyclic dependency
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest discover
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-6ed673966615f3e818e00de4b7e59c27f0a0d7b494294f804540777c580480870c36002c08d8ad626b7b41a676fe40edc0b0b5ffc6ad8080f38f59c24e157636 sphinxcontrib-htmlhelp-2.0.0.tar.gz
+7957ad688d7f9d44c0413fd747147e8e261136d48ed159fef4e668dcab76c54103028102a9ed893bfadbd175b88543e0d1414b8e01a716810d44b92edfbd79e5 sphinxcontrib-htmlhelp-2.0.1.tar.gz
"