aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-sphinxcontrib-jsmath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-sphinxcontrib-jsmath/APKBUILD')
-rw-r--r--main/py3-sphinxcontrib-jsmath/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/py3-sphinxcontrib-jsmath/APKBUILD b/main/py3-sphinxcontrib-jsmath/APKBUILD
index 944eadfa1d6..50e35bd03b5 100644
--- a/main/py3-sphinxcontrib-jsmath/APKBUILD
+++ b/main/py3-sphinxcontrib-jsmath/APKBUILD
@@ -2,22 +2,26 @@
pkgname=py3-sphinxcontrib-jsmath
_pyname=sphinxcontrib-jsmath
pkgver=1.0.1
-pkgrel=1
+pkgrel=7
pkgdesc="Sphinx jsmath extension"
-url="https://pypi.python.org/pypi/sphinxcontrib-jsmath"
+url="https://pypi.org/project/sphinxcontrib-jsmath"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
+options="!check"
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="c1e6488f5c0ca4567c27ec7c597c9db321ac32ce354c4ad62fea534b2ae1c0acb183a921f46216bbc3891f14acfaac05ddf324b8fdaf99828df07bc91aa7e5c7 sphinxcontrib-jsmath-1.0.1.tar.gz"
+sha512sums="
+c1e6488f5c0ca4567c27ec7c597c9db321ac32ce354c4ad62fea534b2ae1c0acb183a921f46216bbc3891f14acfaac05ddf324b8fdaf99828df07bc91aa7e5c7 sphinxcontrib-jsmath-1.0.1.tar.gz
+"