aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-tz/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-tz/APKBUILD')
-rw-r--r--main/py3-tz/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/py3-tz/APKBUILD b/main/py3-tz/APKBUILD
index 1c38ea8c48e..94db0dc0f1f 100644
--- a/main/py3-tz/APKBUILD
+++ b/main/py3-tz/APKBUILD
@@ -1,17 +1,16 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-tz
-_pkgname=pytz
-pkgver=2020.5
+pkgver=2022.6
pkgrel=0
pkgdesc="Python3 definitions of world timezone"
-url="http://pytz.sourceforge.net/"
+url="https://pythonhosted.org/pytz/"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
-source="https://pypi.io/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="https://pypi.python.org/packages/source/p/pytz/pytz-$pkgver.tar.gz"
+builddir="$srcdir/pytz-$pkgver"
replaces="py-tz" # Backwards compatibility
provides="py-tz=$pkgver-r$pkgrel" # Backwards compatibility
@@ -29,4 +28,6 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0845c0b7cefb8732e3016568b17ae73232fe6537bac6da89cb1bf911ba5786ee1be6b5e3aa8767225291e3a7e9afd5b8e40e4051671a3a006f9e2f71c551e13e pytz-2020.5.tar.gz"
+sha512sums="
+ea0343453d011e252fba64502984e2a43ea7c7437a211025ca68a4a45178c8aaef4c2b65261434289b21166a99a1941ec9e2d9d26bb3d22a76cbaa421250131d pytz-2022.6.tar.gz
+"